Here are some shortlisted plugins (and references to core functionality that meets requirements) that should be assessed for suitability (in no particular order).

Bold plugins have been reviewed and appear to match requirements.

Strike-thru means the plugin is not suitable for some reason.

“Requires activation” means the plugin has an activation process, so you need to put it in wp-content/plugins, activate it, then you can (potentially) move it to mu-plugins to force-load it for all users.